Trying to get Factorio enabled

It goes through my config but then fails to start. Here is my termbin: https://termbin.com/az75

Any ideas?

Hi MarisaG. I don’t see anything strange in the output of that script. It shows that the server is online and listening on its corresponding ports. Could you show the output of the startup script? Other things you can do is check the log messages.

Regards.

Here is what it shows when I start it:

Here is what I get when I run the details option:

It seems to shut down as soon as it stops reading the config…

Here is my log file:

0.000 2020-06-06 16:38:00; Factorio 0.17.79 (build 47865, linux64, headless)
0.097 Operating system: Linux (Ubuntu 16.04)
0.097 Program arguments: “./factorio” “–start-server” “/home/fctrserver/serverfiles/save1.zip” “–server-settings” “/home/fctrserver/serverfiles/data/fctrserver.json” “–port” “34197” “–rcon-port” “34198” “–rcon-password”
0.097 Read data path: /home/fctrserver/serverfiles/data
0.097 Write data path: /home/fctrserver/serverfiles [40841/49783MB]
0.097 Binaries path: /home/fctrserver/serverfiles/bin
0.108 System info: [CPU: AMD EPYC 7601 32-Core Processor, 1 core, RAM: 1999 MB]
0.108 Environment: DISPLAY= WAYLAND_DISPLAY= DESKTOP_SESSION= XDG_SESSION_DESKTOP= XDG_CURRENT_DESKTOP= __GL_FSAA_MODE= __GL_LOG_MAX_ANISO= __GL_SYNC_TO_VBLANK= __GL_SORT_FBCONFIGS= __GL_YIELD=
0.108 Running in headless mode
0.113 Loading mod core 0.0.0 (data.lua)
0.194 Loading mod base 0.17.79 (data.lua)
0.511 Loading mod base 0.17.79 (data-updates.lua)
0.697 Checksum for core: 2035938594
0.698 Checksum of base: 4156627525
0.979 Prototype list checksum: 2767119397
1.031 Info PlayerData.cpp:68: Local player-data.json available, timestamp 1591429945
1.031 Info PlayerData.cpp:75: Cloud player-data.json unavailable
1.111 Factorio initialised
1.115 Info ServerMultiplayerManager.cpp:138: Quitting multiplayer connection.
1.116 Info ServerMultiplayerManager.cpp:776: updateTick(4294967295) changing state from(Ready) to(Closed)
1.174 Goodbye

I have installed the same game server and I have the same messages in the console log file, but the service is online when I do the details command. I must tell you that I do not have the game so I cannot test the connection to the server.
Have you noticed that you don’t have any syntax errors in the configuration files?

I am running it on ubuntu version 18.04 server

Where would I see that? I’m running on ubuntu 16.04 myself… Want access to my server?

I found the issue - it doesn’t like Ubuntu 16.04. I installed it on a 18.04 server and it works fine… Thanks for the suggestion!

1 Like

It has happened to me many times that some game servers have not worked for me that some versions of linux. Sorry I was late to answer, but I wasn’t home. I’m glad they solved the problem.
Regards.