Random Seed not random!

OS: Ubuntu server 18.04
latest version of LGSM

I have a rust server well 4, none of which will generate a randon seed is i leave seed to “” i just gens the same map over and over.
./rustserver wiipe and ./rustserver wipeall does not change the map seed

##################################
######## Instance Settings ########
##################################

PLACE INSTANCE SETTINGS HERE

These settings will apply to a specific instance

Server Settings

Server Start Settings | https://docs.linuxgsm.com/configuration/start-parameters

More settings available after install in serverfiles/server/rust-server/server.cfg

ip=“69.69.69.69”
port=“28023”
rconport=“28024”
rconpassword=“nope”
rconweb=“1” # Value is: 1 for Facepunch’s web panel; 0 for RCON tools like Rusty or Rustadmin
servername=“Test Server”
maxplayers=“2”

Advanced Start Settings

seed="" # default random; range : 1 to 2147483647 ; used to change or reproduce a procedural map
salt="" # default random; range : unknown range ; used to recover a known setting from an existing map
worldsize=“1000” # default 3000; range : 1000 to 6000 ; map size in meters
saveinterval=“300” # Auto-save in seconds
tickrate=“100” # default 30; range : 15 to 100

Server Start Command | https://docs.linuxgsm.com/configuration/start-parameters#additional-parameters

fn_parms(){

Specific to Rust

if [ -n “${seed}” ]; then
# If set, then add to start parms
conditionalseed="+server.seed ${seed}"
else
# Keep randomness of the number if not set
conditionalseed=""
fi
if [ -n “${salt}” ]; then
# If set, then add to start parms
conditionalsalt="+server.salt ${salt}"
else
# Keep randomness of the number if not set
conditionalsalt=""
fi
parms="-batchmode +server.ip ${ip} +server.port ${port} +server.tickrate ${tickrate} +server.hostname "${servername$
}

LinuxGSM Settings

Notification Alerts

(on|off)

Display IP | https://docs.linuxgsm.com/alerts#display-ip

displayip=""

More info | https://docs.linuxgsm.com/alerts#more-info

postalert=“off”
postdays=“7”
posttarget=“https://hastebin.com

Discord Alerts | https://docs.linuxgsm.com/alerts/discord

discordalert=“off”
discordwebhook=“webhook”

Email Alerts | https://docs.linuxgsm.com/alerts/email

emailalert=“off”

What do?

Thanks for this. I am looking at rust currently so this is good timing for me to test and check this. Please could you raise an issue on github and I will investigate.

surething!

I put this into command_wipe.sh

newseed=$((1 + RANDOM*RANDOM % 2147483647))
sed -i -e ‘17c\seed="’"$newseed"’"’ /home/rustserver/lgsm/config-lgsm/rustserver/rustserver.cfg

says permission denied, I’m still new to linux so a bit more reading i think!

Edit my mistake, i was using the wrong location /home/rust2
this is a working work around!
just remove the seed section from your rustserver.cfg.
this script will add a new random seed then update to a new random seed when you ./rustserver wipe.